<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-0&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-0&cb=5', false, [], true, false, true, false);</script><meta name="viewport" content="width=device-width, initial-scale=1"/><link rel="profile" href="//gmpg.org/xfn/11"/> <script data-cfasync="false" type="text/javascript">var ewww_webp_supported=!1;function check_webp_feature(A,e){if(e=void 0!==e?e:function(){},ewww_webp_supported)e(ewww_webp_supported);else{var w=new Image;w.onload=function(){ewww_webp_supported=0<w.width&&0<w.height,e&&e(ewww_webp_supported)},w.onerror=function(){e&&e(!1)},w.src="data:image/webp;base64,"+{alpha:"UklGRkoAAABXRUJQVlA4WAoAAAAQAAAAAAAAAAAAQUxQSAwAAAARBxAR/Q9ERP8DAABWUDggGAAAABQBAJ0BKgEAAQAAAP4AAA3AAP7mtQAAAA=="}[A]}}check_webp_feature("alpha");</script><script data-cfasync="false" type="text/javascript">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</script><meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1"/><link media="all" href="https://www.newsreports.com/wp-content/cache/autoptimize/css/autoptimize_22af40caaefa3b3e733824737b1359b1.css" rel="stylesheet"/><title>How Much Debt Makes It Worth Filing for Bankruptcy? - Newsreports</title><meta name="description" content="Most people in the U.S. have some degree of debt. While debt is manageable for some, it’s not so manageable for others."/><link rel="canonical" href="https://www.newsreports.com/debt-filing-for-bankruptcy/"/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta property="og:title" content="How Much Debt Makes It Worth Filing for Bankruptcy?"/><meta property="og:description" content="Most people in the U.S. have some degree of debt. While debt is manageable for some, it’s not so manageable for others."/><meta property="og:url" content="https://www.newsreports.com/debt-filing-for-bankruptcy/"/><meta property="og:site_name" content="Newsreports"/><meta property="article:published_time" content="2021-12-21T08:00:49+00:00"/><meta property="article:modified_time" content="2021-12-20T19:32:23+00:00"/><meta property="og:image" content="https://www.newsreports.com/wp-content/uploads/2021/12/How-Much-Debt-Makes-It-Worth-Filing-for-Bankruptcy.jpg"/><meta property="og:image:width" content="1920"/><meta property="og:image:height" content="1280"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:label1" content="Written by"/><meta name="twitter:data1" content="Sofia Hernandez"/><meta name="twitter:label2" content="Est. reading time"/><meta name="twitter:data2" content="4 minutes"/> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.newsreports.com/#website","url":"https://www.newsreports.com/","name":"Newsreports","description":"Daily News from around the world","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.newsreports.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.newsreports.com/debt-filing-for-bankruptcy/#primaryimage","inLanguage":"en-US","url":"https://www.newsreports.com/wp-content/uploads/2021/12/How-Much-Debt-Makes-It-Worth-Filing-for-Bankruptcy.jpg","contentUrl":"https://www.newsreports.com/wp-content/uploads/2021/12/How-Much-Debt-Makes-It-Worth-Filing-for-Bankruptcy.jpg","width":1920,"height":1280,"caption":"How Much Debt Makes It Worth Filing for Bankruptcy?"},{"@type":"WebPage","@id":"https://www.newsreports.com/debt-filing-for-bankruptcy/#webpage","url":"https://www.newsreports.com/debt-filing-for-bankruptcy/","name":"How Much Debt Makes It Worth Filing for Bankruptcy? - Newsreports","isPartOf":{"@id":"https://www.newsreports.com/#website"},"primaryImageOfPage":{"@id":"https://www.newsreports.com/debt-filing-for-bankruptcy/#primaryimage"},"datePublished":"2021-12-21T08:00:49+00:00","dateModified":"2021-12-20T19:32:23+00:00","author":{"@id":"https://www.newsreports.com/#/schema/person/96a493201ffa01735745ccb2fbb4410c"},"description":"Most people in the U.S. have some degree of debt. While debt is manageable for some, it\u2019s not so manageable for others.","breadcrumb":{"@id":"https://www.newsreports.com/debt-filing-for-bankruptcy/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.newsreports.com/debt-filing-for-bankruptcy/"]}]},{"@type":"BreadcrumbList","@id":"https://www.newsreports.com/debt-filing-for-bankruptcy/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"How Much Debt Makes It Worth Filing for Bankruptcy?"}]},{"@type":"Person","@id":"https://www.newsreports.com/#/schema/person/96a493201ffa01735745ccb2fbb4410c","name":"Sofia Hernandez","image":{"@type":"ImageObject","@id":"https://www.newsreports.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/dea381549dab9e2ce08bd6c017688db9?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/dea381549dab9e2ce08bd6c017688db9?s=96&d=mm&r=g","caption":"Sofia Hernandez"},"description":"Sofia Hernandez has written for several media outlets, and she now oversees NewsReports as its editor.","url":"https://www.newsreports.com/author/sofia-hernandez/"}]}</script> <link rel="alternate" type="application/rss+xml" title="Newsreports » Feed" href="https://www.newsreports.com/feed/"/><link rel="alternate" type="application/rss+xml" title="Newsreports » Comments Feed" href="https://www.newsreports.com/comments/feed/"/><link rel="alternate" type="application/rss+xml" title="Newsreports » How Much Debt Makes It Worth Filing for Bankruptcy? Comments Feed" href="https://www.newsreports.com/debt-filing-for-bankruptcy/feed/"/><style id="elementor-frontend-inline-css" type="text/css">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</style><link rel="stylesheet" id="google-fonts-1-css" href="https://fonts.googleapis.com/css?family=Poppins%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic%7CPlayfair+Display%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic%7CArchivo%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic%7CBarlow+Condensed%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic%7CArchivo+Black%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic&amp;display=auto&amp;ver=5.8.2" type="text/css" media="all"/> <script type="text/javascript" src="https://www.newsreports.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0" id="jquery-core-js"></script> <link rel="https://api.w.org/" href="https://www.newsreports.com/wp-json/"/><link rel="alternate" type="application/json" href="https://www.newsreports.com/wp-json/wp/v2/posts/93378"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.newsreports.com/xmlrpc.php?rsd"/><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.newsreports.com/wp-includes/wlwmanifest.xml"/><meta name="generator" content="WordPress 5.8.2"/><link rel="shortlink" href="https://www.newsreports.com/?p=93378"/><link rel="alternate" type="application/json+oembed" href="https://www.newsreports.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.newsreports.com%2Fdebt-filing-for-bankruptcy%2F"/><link rel="alternate" type="text/xml+oembed" href="https://www.newsreports.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.newsreports.com%2Fdebt-filing-for-bankruptcy%2F&amp;format=xml"/><link rel="shortcut icon" href="https://www.newsreports.com/wp-content/themes/newsreports/assets/images/favicon.ico"/><noscript><style>.lazyload[data-src]{display:none !important;}</style></noscript><link rel="icon" href="https://www.newsreports.com/wp-content/uploads/2021/11/cropped-favicon-1-32x32.png" sizes="32x32"/><link rel="icon" href="https://www.newsreports.com/wp-content/uploads/2021/11/cropped-favicon-1-192x192.png" sizes="192x192"/><link rel="apple-touch-icon" href="https://www.newsreports.com/wp-content/uploads/2021/11/cropped-favicon-1-180x180.png"/><meta name="msapplication-TileImage" content="https://www.newsreports.com/wp-content/uploads/2021/11/cropped-favicon-1-270x270.png"/><script type="text/javascript">var ezouid = "1";</script><base href="https://www.newsreports.com/debt-filing-for-bankruptcy/"><script type='text/javascript'>
var ezoTemplate = 'old_site_noads';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 309703;
var ezdomain = 'newsreports.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":309703,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"698c580d-c011-4d5f-7959-498bf7099ede","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":268252,"response_time_orig":6,"serverid":"3.236.161.254:10397","state":"VA","t_epoch":1640092385,"template_id":120,"time_on_site_visit":0,"url":"https://www.newsreports.com/debt-filing-for-bankruptcy/","user_id":0,"word_count":961,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_309703=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["698c580d-c011-4d5f-7959-498bf7099ede", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head><body class="post-template-default single single-post postid-93378 single-format-standard wp-custom-logo elementor-default elementor-kit-84305 elementor-page-84355">
<script data-cfasync="false">if(ewww_webp_supported){document.body.classList.add("webp-support");}</script><header data-elementor-type="header" data-elementor-id="84369" class="elementor elementor-84369 elementor-location-header" data-elementor-settings="[]"><div class="elementor-section-wrap"><section class="elementor-section elementor-top-section elementor-element elementor-element-75e25825 elementor-section-height-min-height elementor-section-content-middle elementor-section-boxed elementor-section-height-default elementor-section-items-middle" data-id="75e25825" data-element_type="section" data-settings="{&#34;sticky&#34;:&#34;top&#34;,&#34;background_background&#34;:&#34;classic&#34;,&#34;sticky_on&#34;:[&#34;desktop&#34;,&#34;tablet&#34;,&#34;mobile&#34;],&#34;sticky_offset&#34;:0,&#34;sticky_effects_offset&#34;:0}"><div class="elementor-container elementor-column-gap-no"><div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-6af9e586" data-id="6af9e586" data-element_type="column"><div class="elementor-widget-wrap elementor-element-populated"><div class="elementor-element elementor-element-6430174f elementor-widget__width-auto elementor-widget elementor-widget-theme-site-logo elementor-widget-image" data-id="6430174f" data-element_type="widget" data-widget_type="theme-site-logo.default"><div class="elementor-widget-container"> <a href="https://www.newsreports.com"> <img width="228" height="37" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="attachment-full size-full ewww_webp" alt="" data-src-img="https://www.newsreports.com/wp-content/uploads/2021/11/newsreports1.png" data-src-webp="https://www.newsreports.com/wp-content/uploads/2021/11/newsreports1.png.webp" data-eio="j"/><noscript><img width="228" height="37" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="attachment-full size-full ewww_webp" alt="" data-src-img="https://www.newsreports.com/wp-content/uploads/2021/11/newsreports1.png" data-src-webp="https://www.newsreports.com/wp-content/uploads/2021/11/newsreports1.png.webp" data-eio="j" /><noscript><img width="228" height="37" src="https://www.newsreports.com/wp-content/uploads/2021/11/newsreports1.png" class="attachment-full size-full" alt="" /></noscript> </a></div></div><div class="elementor-element elementor-element-1c6caca6 elementor-nav-menu__align-center elementor-widget__width-auto elementor-nav-menu--dropdown-mobile elementor-nav-menu--stretch elementor-widget-mobile__width-initial elementor-nav-menu__text-align-aside elementor-nav-menu--toggle elementor-nav-menu--burger elementor-widget elementor-widget-nav-menu" data-id="1c6caca6" data-element_type="widget" data-settings="{&#34;full_width&#34;:&#34;stretch&#34;,&#34;layout&#34;:&#34;horizontal&#34;,&#34;submenu_icon&#34;:{&#34;value&#34;:&#34;&lt;i class=\&#34;fas fa-caret-down\&#34;&gt;&lt;\/i&gt;&#34;,&#34;library&#34;:&#34;fa-solid&#34;},&#34;toggle&#34;:&#34;burger&#34;}" data-widget_type="nav-menu.default"><div class="elementor-widget-container"><nav migration_allowed="1" migrated="0" role="navigation" class="elementor-nav-menu--main elementor-nav-menu__container elementor-nav-menu--layout-horizontal e--pointer-underline e--animation-fade"><ul id="menu-1-1c6caca6" class="elementor-nav-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92870"><a href="https://www.newsreports.com/category/tech/" class="elementor-item">Tech</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92883"><a href="https://www.newsreports.com/category/news/" class="elementor-item">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92880"><a href="https://www.newsreports.com/category/business/" class="elementor-item">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92999"><a href="https://www.newsreports.com/category/health/" class="elementor-item">Health</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-1779"><a href="https://www.newsreports.com/category/apps/" class="elementor-item">Apps</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1770"><a href="https://www.newsreports.com/category/games/" class="elementor-item">Games</a></li></ul></nav><div class="elementor-menu-toggle" role="button" tabindex="0" aria-label="Menu Toggle" aria-expanded="false"> <i aria-hidden="true" role="presentation" class="eicon-menu-bar"></i> <span class="elementor-screen-only">Menu</span></div><nav class="elementor-nav-menu--dropdown elementor-nav-menu__container" role="navigation" aria-hidden="true"><ul id="menu-2-1c6caca6" class="elementor-nav-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92870"><a href="https://www.newsreports.com/category/tech/" class="elementor-item" tabindex="-1">Tech</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92883"><a href="https://www.newsreports.com/category/news/" class="elementor-item" tabindex="-1">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92880"><a href="https://www.newsreports.com/category/business/" class="elementor-item" tabindex="-1">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92999"><a href="https://www.newsreports.com/category/health/" class="elementor-item" tabindex="-1">Health</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-1779"><a href="https://www.newsreports.com/category/apps/" class="elementor-item" tabindex="-1">Apps</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1770"><a href="https://www.newsreports.com/category/games/" class="elementor-item" tabindex="-1">Games</a></li></ul></nav></div></div><div class="elementor-element elementor-element-56edb495 elementor-search-form--skin-full_screen elementor-widget__width-auto elementor-widget elementor-widget-search-form" data-id="56edb495" data-element_type="widget" data-settings="{&#34;skin&#34;:&#34;full_screen&#34;}" data-widget_type="search-form.default"><div class="elementor-widget-container"><form class="elementor-search-form" role="search" action="https://www.newsreports.com" method="get"><div class="elementor-search-form__toggle"> <i aria-hidden="true" class="fas fa-search"></i> <span class="elementor-screen-only">Search</span></div><div class="elementor-search-form__container"> <input placeholder="Search..." class="elementor-search-form__input" type="search" name="s" title="Search" value=""/><div class="dialog-lightbox-close-button dialog-close-button"> <i aria-hidden="true" class="eicon-close"></i> <span class="elementor-screen-only">Close</span></div></div></form></div></div></div></div></div></section></div></header><div data-elementor-type="single-post" data-elementor-id="84355" class="elementor elementor-84355 elementor-location-single post-93378 post type-post status-publish format-standard has-post-thumbnail hentry category-finance tag-bankruptcy tag-budgeting tag-debt tag-finances" data-elementor-settings="[]"><div class="elementor-section-wrap"><section class="elementor-section elementor-top-section elementor-element elementor-element-574cedc6 elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="574cedc6" data-element_type="section"><div class="elementor-container elementor-column-gap-no"><div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-7e12863c" data-id="7e12863c" data-element_type="column"><div class="elementor-widget-wrap elementor-element-populated"><div class="elementor-element elementor-element-1f35a656 elementor-widget elementor-widget-heading" data-id="1f35a656" data-element_type="widget" data-widget_type="heading.default"><div class="elementor-widget-container"><h1 class="elementor-heading-title elementor-size-default">How Much Debt Makes It Worth Filing for Bankruptcy?</h1></div></div></div></div></div></section><section class="elementor-section elementor-top-section elementor-element elementor-element-2e418d7c elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="2e418d7c" data-element_type="section"><div class="elementor-container elementor-column-gap-no"><div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-20a42e0f" data-id="20a42e0f" data-element_type="column"><div class="elementor-widget-wrap elementor-element-populated"><div class="elementor-element elementor-element-357597d8 elementor-align-center elementor-widget elementor-widget-post-info" data-id="357597d8" data-element_type="widget" data-widget_type="post-info.default"><div class="elementor-widget-container"><ul class="elementor-inline-items elementor-icon-list-items elementor-post-info"><li class="elementor-icon-list-item elementor-repeater-item-dba0f34 elementor-inline-item" itemprop="datePublished"> <span class="elementor-icon-list-text elementor-post-info__item elementor-post-info__item--type-date"> December 21, 2021 </span></li><li class="elementor-icon-list-item elementor-repeater-item-b9d4815 elementor-inline-item" itemprop="author"> <span class="elementor-icon-list-text elementor-post-info__item elementor-post-info__item--type-author"> <span class="elementor-post-info__item-prefix">by</span> Sofia Hernandez </span></li></ul></div></div><div class="elementor-element elementor-element-6e561bf5 elementor-widget elementor-widget-spacer" data-id="6e561bf5" data-element_type="widget" data-widget_type="spacer.default"><div class="elementor-widget-container"><div class="elementor-spacer"><div class="elementor-spacer-inner"></div></div></div></div><div class="elementor-element elementor-element-6faed9e1 elementor-widget__width-auto elementor-widget elementor-widget-heading" data-id="6faed9e1" data-element_type="widget" data-widget_type="heading.default"><div class="elementor-widget-container"><p class="elementor-heading-title elementor-size-default">Share Article</p></div></div><div class="elementor-element elementor-element-5231bcb elementor-share-buttons--view-icon elementor-share-buttons--skin-flat elementor-share-buttons--color-custom elementor-widget__width-auto elementor-share-buttons--shape-square elementor-grid-0 elementor-widget elementor-widget-share-buttons" data-id="5231bcb" data-element_type="widget" data-widget_type="share-buttons.default"><div class="elementor-widget-container"><div class="elementor-grid"><div class="elementor-grid-item"><div class="elementor-share-btn elementor-share-btn_facebook"> <span class="elementor-share-btn__icon"> <i class="fab fa-facebook" aria-hidden="true"></i> <span class="elementor-screen-only">Share on facebook</span> </span></div></div><div class="elementor-grid-item"><div class="elementor-share-btn elementor-share-btn_twitter"> <span class="elementor-share-btn__icon"> <i class="fab fa-twitter" aria-hidden="true"></i> <span class="elementor-screen-only">Share on twitter</span> </span></div></div><div class="elementor-grid-item"><div class="elementor-share-btn elementor-share-btn_reddit"> <span class="elementor-share-btn__icon"> <i class="fab fa-reddit" aria-hidden="true"></i> <span class="elementor-screen-only">Share on reddit</span> </span></div></div></div></div></div></div></div></div></section><section class="elementor-section elementor-top-section elementor-element elementor-element-777cb4c2 elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="777cb4c2" data-element_type="section"><div class="elementor-container elementor-column-gap-no"><div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-61e69cd8" data-id="61e69cd8" data-element_type="column"><div class="elementor-widget-wrap elementor-element-populated"><div class="elementor-element elementor-element-2add1a70 elementor-widget elementor-widget-theme-post-excerpt" data-id="2add1a70" data-element_type="widget" data-widget_type="theme-post-excerpt.default"><div class="elementor-widget-container"> Most people in the U.S. have some degree of debt. While debt is manageable for some, it’s not so manageable for others.</div></div><div class="elementor-element elementor-element-6c2c7f3c elementor-widget elementor-widget-theme-post-content" data-id="6c2c7f3c" data-element_type="widget" data-widget_type="theme-post-content.default"><div class="elementor-widget-container"><p>Most people in the U.S. have some degree of debt. While debt is manageable for some, it’s not so manageable for others. Those who feel no hope in paying back their debts usually consider bankruptcy, but only as a last resort.</p><p>While bankruptcy is certainly an option for many entrepreneurs, it may not be the best choice depending on your debt size. For example, someone who is $300,000 in debt is an obvious candidate for bankruptcy, while someone $7,000 in debt might not benefit much because of the filing fees.</p><p>There’s no specific threshold for how much debt you need to file for bankruptcy. Whether or not you should file depends entirely on your personal situation, including your income, your debt, and your ability to pay back your debt (or not).</p><h2>Are you willing to obtain legal counsel?</h2><p>The first question to ask yourself is if you’re willing to obtain legal counsel for your bankruptcy case. The court system is unforgiving to those who choose self-representation and it’s not worth risking a poor outcome.</p><p>First and foremost, in order <a href="https://dozierlaw.com/practice-areas/bankruptcy/" target="_blank" rel="noopener">to file for bankruptcy, you need an attorney</a>. Whether you’re filing under Chapter 7 or 13, a bankruptcy attorney will help you get the best outcome. For instance, if you proceed without a lawyer, you might not know how to convince a court you qualify for getting a blank slate under Chapter 7.</p><p>Inexperience in the courtroom could end with the court only approving you for Chapter 13, where you’ll need to pay back all of your debt on a pre-set payment schedule over several years.</p><p>There’s nothing wrong with paying back your debt incrementally when you can truly afford to make the payments, but you might need to seriously restructure your life to <a href="https://www.newsreports.com/financial-success-strategies/" target="_blank" rel="noopener">make it work</a>; that’s why you need a bankruptcy attorney.</p><h2>Are you a good candidate for bankruptcy?</h2><p>There are many types of bankruptcy, but most people are familiar with Chapter 7 and Chapter 13. Chapter 7 is where your debts are eliminated completely, while Chapter 13 requires paying your debts over three to five years with income-based payments. Everyone wants to qualify for Chapter 7, but not everyone does.</p><p>It’s impossible to say whether anyone should or should not file for bankruptcy. It’s not a yes or no question. While you’ll need to consult an attorney for a definitive answer, <a href="https://www.debt.org/bankruptcy/should-i-file/" target="_blank" rel="noopener">you’re a good candidate for bankruptcy</a> if you meet the following conditions:</p><ul><li style="font-weight: 400;" aria-level="1">You have unsecured debt you can’t pay back.</li><li style="font-weight: 400;" aria-level="1">You’re getting sued by creditors for money you don’t have.</li><li style="font-weight: 400;" aria-level="1">Your house is in danger of foreclosure.</li><li style="font-weight: 400;" aria-level="1">You’re living off of your credit cards.</li><li style="font-weight: 400;" aria-level="1">You’ve thought about withdrawing money from your 401(k) to pay your bills.</li><li style="font-weight: 400;" aria-level="1">There is no other way to reduce or eliminate your debt with your creditor.</li><li style="font-weight: 400;" aria-level="1">Other debt relief programs haven’t worked, or you don’t want to go through additional processes.</li><li style="font-weight: 400;" aria-level="1">Credit counseling didn’t work and you need a faster solution.</li><li style="font-weight: 400;" aria-level="1">You’re afraid of getting swindled by a debt consolidation scam.</li><li style="font-weight: 400;" aria-level="1">You’re willing to work out a payment plan if necessary.</li><li style="font-weight: 400;" aria-level="1">You don’t mind having bad credit for the next seven years.</li><li style="font-weight: 400;" aria-level="1">You’re not afraid of the social stigma surrounding bankruptcy.</li></ul><p>This list isn’t exhaustive, and you’ll need to consult with a lawyer to know for sure if your particular situation qualifies and what assets you might need to sell if you’re a candidate for Chapter 13.</p><h2>Are you willing to sell your assets?</h2><p>The next consideration is whether you are willing to sell your assets (if you have any). If you have assets that can cover your debt, you probably won’t qualify for Chapter 7. Instead, you’ll likely be approved for Chapter 13, provided you agree to sell certain assets to cover your debt.</p><h2>There is no shame in filing for bankruptcy.</h2><p>Most people end up considering bankruptcy at some point in their life and there’s no shame in needing help to get out of debt. Although, personal bankruptcy rates are going down</p><p>Bankruptcy filings in the United States have been dropping in recent years. Personal filings dropped by nearly 30% in 2020 and dropped again by <a href="https://www.uscourts.gov/news/2021/05/03/new-bankruptcy-filings-plummet-381-percent" target="_blank" rel="noopener">38% in 2021</a>.</p><p>As of March 2021, there were 453,438 personal bankruptcies filed in the previous 12 months, which is a drastic decline from 2017 when personal filings were up to 770,901.</p><p>Whether you choose to file or not, <a href="https://www.newsreports.com/ideal-it-budget-tips/" target="_blank" rel="noopener">start budgeting</a> and downsize your life wherever possible. It can be hard to maintain a lower standard of living after you’ve lived a different way for so long, but it’s the best way to ensure you never have to consider bankruptcy again.</p></div></div><div class="elementor-element elementor-element-65964500 elementor-widget elementor-widget-post-navigation" data-id="65964500" data-element_type="widget" data-widget_type="post-navigation.default"><div class="elementor-widget-container"><div class="elementor-post-navigation"><div class="elementor-post-navigation__prev elementor-post-navigation__link"> <a href="https://www.newsreports.com/christmas-rush-business-crush/" rel="prev"><span class="elementor-post-navigation__link__prev"><span class="post-navigation__prev--label">Previous</span></span></a></div><div class="elementor-post-navigation__next elementor-post-navigation__link"></div></div></div></div><div class="elementor-element elementor-element-6673f972 elementor-widget elementor-widget-heading" data-id="6673f972" data-element_type="widget" data-widget_type="heading.default"><div class="elementor-widget-container"><h3 class="elementor-heading-title elementor-size-default">You might also like</h3></div></div><div class="elementor-element elementor-element-2b69abf1 elementor-grid-2 elementor-grid-tablet-2 elementor-grid-mobile-1 elementor-posts--thumbnail-top elementor-posts__hover-gradient elementor-widget elementor-widget-posts" data-id="2b69abf1" data-element_type="widget" data-settings="{&#34;cards_row_gap&#34;:{&#34;unit&#34;:&#34;px&#34;,&#34;size&#34;:60,&#34;sizes&#34;:[]},&#34;cards_columns&#34;:&#34;2&#34;,&#34;cards_columns_tablet&#34;:&#34;2&#34;,&#34;cards_columns_mobile&#34;:&#34;1&#34;,&#34;cards_row_gap_tablet&#34;:{&#34;unit&#34;:&#34;px&#34;,&#34;size&#34;:&#34;&#34;,&#34;sizes&#34;:[]},&#34;cards_row_gap_mobile&#34;:{&#34;unit&#34;:&#34;px&#34;,&#34;size&#34;:&#34;&#34;,&#34;sizes&#34;:[]}}" data-widget_type="posts.cards"><div class="elementor-widget-container"><div class="elementor-posts-container elementor-posts elementor-posts--skin-cards elementor-grid"><article class="elementor-post elementor-grid-item post-10007 post type-post status-publish format-standard hentry category-games"><div class="elementor-post__card"><div class="elementor-post__text"><h4 class="elementor-post__title"> <a href="https://www.newsreports.com/myst-iphone-game-app-mimics-pc-version-but-has-key-flaw/" target="&#34;_blank&#34;"> Myst iPhone game app mimics PC version but has key flaw </a></h4><div class="elementor-post__excerpt"><p>Myst is a best-selling PC game reincarnated for the iPhone and iPod touch. Using logic and deductive skills, you advance through the game, piecing the</p></div></div><div class="elementor-post__meta-data"> <span class="elementor-post-date"> August 6, 2009 </span></div></div></article><article class="elementor-post elementor-grid-item post-10008 post type-post status-publish format-standard hentry category-misc"><div class="elementor-post__card"><div class="elementor-post__text"><h4 class="elementor-post__title"> <a href="https://www.newsreports.com/why-i-like-myfantasyteams-pro/" target="&#34;_blank&#34;"> Why I like MyFantasyTeams Pro </a></h4><div class="elementor-post__excerpt"><p>I’ve sampled a number of fantasy sports websites, but I always seem to go back to Yahoo! Fantasy Sports. The site is not necessarily the best</p></div></div><div class="elementor-post__meta-data"> <span class="elementor-post-date"> August 6, 2009 </span></div></div></article></div></div></div></div></div></div></section><section class="elementor-section elementor-top-section elementor-element elementor-element-61f823d elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="61f823d" data-element_type="section"><div class="elementor-container elementor-column-gap-no"><div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-370a4f61" data-id="370a4f61" data-element_type="column"><div class="elementor-widget-wrap elementor-element-populated"><div class="elementor-element elementor-element-4219c842 elementor-widget elementor-widget-heading" data-id="4219c842" data-element_type="widget" data-widget_type="heading.default"><div class="elementor-widget-container"><h2 class="elementor-heading-title elementor-size-default">#apps</h2></div></div></div></div></div></section></div></div><footer data-elementor-type="footer" data-elementor-id="84364" class="elementor elementor-84364 elementor-location-footer" data-elementor-settings="[]"><div class="elementor-section-wrap"><section class="elementor-section elementor-top-section elementor-element elementor-element-10162ab1 elementor-section-content-top elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="10162ab1" data-element_type="section" data-settings="{&#34;background_background&#34;:&#34;classic&#34;}"><div class="elementor-container elementor-column-gap-no"><div class="elementor-column elementor-col-33 elementor-top-column elementor-element elementor-element-693d9e84" data-id="693d9e84" data-element_type="column"><div class="elementor-widget-wrap elementor-element-populated"><div class="elementor-element elementor-element-2ecd7ef3 elementor-widget elementor-widget-theme-site-logo elementor-widget-image" data-id="2ecd7ef3" data-element_type="widget" data-widget_type="theme-site-logo.default"><div class="elementor-widget-container"> <a href="https://www.newsreports.com"> <img width="228" height="37" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="attachment-full size-full ewww_webp" alt="" data-src-img="https://www.newsreports.com/wp-content/uploads/2021/11/newsreports1.png" data-src-webp="https://www.newsreports.com/wp-content/uploads/2021/11/newsreports1.png.webp" data-eio="j"/><noscript><img width="228" height="37" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="attachment-full size-full ewww_webp" alt="" data-src-img="https://www.newsreports.com/wp-content/uploads/2021/11/newsreports1.png" data-src-webp="https://www.newsreports.com/wp-content/uploads/2021/11/newsreports1.png.webp" data-eio="j" /><noscript><img width="228" height="37" src="https://www.newsreports.com/wp-content/uploads/2021/11/newsreports1.png" class="attachment-full size-full" alt="" /></noscript> </a></div></div><div class="elementor-element elementor-element-30d0661c elementor-widget elementor-widget-text-editor" data-id="30d0661c" data-element_type="widget" data-widget_type="text-editor.default"><div class="elementor-widget-container"> Daily News from around the world</div></div><div class="elementor-element elementor-element-1ff0011b e-grid-align-left e-grid-align-tablet-center elementor-shape-rounded elementor-grid-0 elementor-widget elementor-widget-social-icons" data-id="1ff0011b" data-element_type="widget" data-widget_type="social-icons.default"><div class="elementor-widget-container"><div class="elementor-social-icons-wrapper elementor-grid"> <span class="elementor-grid-item"> <a class="elementor-icon elementor-social-icon elementor-social-icon-facebook-f elementor-repeater-item-447f7fb" href="https://www.facebook.com/newsreportscom" target="_blank"> <span class="elementor-screen-only">Facebook-f</span> <i class="fab fa-facebook-f"></i> </a> </span> <span class="elementor-grid-item"> <a class="elementor-icon elementor-social-icon elementor-social-icon- elementor-repeater-item-9376af4" target="_blank"> <span class="elementor-screen-only"></span> <svg xmlns="http://www.w3.org/2000/svg" id="a5b66522-2d0b-4d2b-9ca0-25f662c860cf" data-name="Layer 1" viewBox="0 0 26 26"><g id="b72f5698-1c43-4a08-8b57-8ac749a07216" data-name="Page-1"><g id="f731df14-8d9a-4002-8f9a-a848309208fa" data-name="Homepage"><g id="bdfa7f62-b961-47b8-873b-1fb70dc137d1" data-name="Sticky-Social-Icons"><g id="f7176559-406d-4faa-b9a3-f0818c0693ca" data-name="Group-5"><path id="e8aaf532-0893-42c1-aea8-a21edf8137c2" data-name="Fill-1" d="M23.1073,4.3306A1.4446,1.4446,0,1,0,21.663,5.7791a1.45,1.45,0,0,0,1.4443-1.4485ZM13.01,5.7807a7.2151,7.2151,0,1,0,7.208,7.2146A7.2075,7.2075,0,0,0,13.01,5.7807ZM25.9918,13.12c0,1.9159.022,3.8322-.006,5.7476a7.2237,7.2237,0,0,1-5.399,6.8873,6.8057,6.8057,0,0,1-1.7214.2295c-3.9072.0017-7.8149.0427-11.7212-.0132a6.97,6.97,0,0,1-6.27-3.7959,6.7,6.7,0,0,1-.8578-3.3476c-.0046-3.8968-.04-7.794.0115-11.69A6.97,6.97,0,0,1,3.7357.9106a6.867,6.867,0,0,1,3.53-.907c3.8819.001,7.764-.0125,11.6456.0071a6.8893,6.8893,0,0,1,4.5545,1.7279A7.03,7.03,0,0,1,25.8718,5.93a7.7869,7.7869,0,0,1,.1155,1.3339c.012,1.9519.0052,3.904.0052,5.8559Z" transform="translate(0 0)" style="fill-rule:evenodd"></path><path id="ae30d5b5-b0cd-4931-87e3-deb52029baa9" data-name="Fill-3" d="M12.9971,8.3571a4.6429,4.6429,0,1,1-4.64,4.6445,4.6422,4.6422,0,0,1,4.64-4.6445" transform="translate(0 0)" style="fill-rule:evenodd"></path></g></g></g></g></svg> </a> </span> <span class="elementor-grid-item"> <a class="elementor-icon elementor-social-icon elementor-social-icon-twitter elementor-repeater-item-7259153" target="_blank"> <span class="elementor-screen-only">Twitter</span> <i class="fab fa-twitter"></i> </a> </span></div></div></div></div></div><div class="elementor-column elementor-col-66 elementor-top-column elementor-element elementor-element-5e277a7e" data-id="5e277a7e" data-element_type="column"><div class="elementor-widget-wrap elementor-element-populated"><div class="elementor-element elementor-element-9c2cf49 elementor-widget elementor-widget-menu-anchor" data-id="9c2cf49" data-element_type="widget" data-widget_type="menu-anchor.default"><div class="elementor-widget-container"><div class="elementor-menu-anchor"></div></div></div><div class="elementor-element elementor-element-61fe024 elementor-nav-menu__align-left elementor-nav-menu--dropdown-tablet elementor-nav-menu__text-align-aside elementor-nav-menu--toggle elementor-nav-menu--burger elementor-widget elementor-widget-nav-menu" data-id="61fe024" data-element_type="widget" data-settings="{&#34;layout&#34;:&#34;horizontal&#34;,&#34;submenu_icon&#34;:{&#34;value&#34;:&#34;&lt;i class=\&#34;fas fa-caret-down\&#34;&gt;&lt;\/i&gt;&#34;,&#34;library&#34;:&#34;fa-solid&#34;},&#34;toggle&#34;:&#34;burger&#34;}" data-widget_type="nav-menu.default"><div class="elementor-widget-container"><nav migration_allowed="1" migrated="0" role="navigation" class="elementor-nav-menu--main elementor-nav-menu__container elementor-nav-menu--layout-horizontal e--pointer-underline e--animation-fade"><ul id="menu-1-61fe024" class="elementor-nav-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84493"><a href="https://www.newsreports.com/about-us/" class="elementor-item">About Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84492"><a href="https://www.newsreports.com/contact-us/" class="elementor-item">Contact us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84537"><a href="https://www.newsreports.com/contributors/" class="elementor-item">Contributors</a></li></ul></nav><div class="elementor-menu-toggle" role="button" tabindex="0" aria-label="Menu Toggle" aria-expanded="false"> <i aria-hidden="true" role="presentation" class="eicon-menu-bar"></i> <span class="elementor-screen-only">Menu</span></div><nav class="elementor-nav-menu--dropdown elementor-nav-menu__container" role="navigation" aria-hidden="true"><ul id="menu-2-61fe024" class="elementor-nav-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84493"><a href="https://www.newsreports.com/about-us/" class="elementor-item" tabindex="-1">About Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84492"><a href="https://www.newsreports.com/contact-us/" class="elementor-item" tabindex="-1">Contact us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84537"><a href="https://www.newsreports.com/contributors/" class="elementor-item" tabindex="-1">Contributors</a></li></ul></nav></div></div><div class="elementor-element elementor-element-566db580 elementor-widget elementor-widget-heading" data-id="566db580" data-element_type="widget" data-widget_type="heading.default"><div class="elementor-widget-container"><h5 class="elementor-heading-title elementor-size-default">Be the first to know</h5></div></div><div class="elementor-element elementor-element-2646d00d elementor-widget elementor-widget-text-editor" data-id="2646d00d" data-element_type="widget" data-widget_type="text-editor.default"><div class="elementor-widget-container"> Subscribe to receive life-changing weekly updates</div></div><div class="elementor-element elementor-element-69f6bf5b elementor-mobile-button-align-stretch elementor-button-align-stretch elementor-widget elementor-widget-form" data-id="69f6bf5b" data-element_type="widget" data-settings="{&#34;button_width&#34;:&#34;40&#34;,&#34;step_next_label&#34;:&#34;Next&#34;,&#34;step_previous_label&#34;:&#34;Previous&#34;,&#34;button_width_mobile&#34;:&#34;100&#34;,&#34;button_width_tablet&#34;:&#34;50&#34;,&#34;step_type&#34;:&#34;number_text&#34;,&#34;step_icon_shape&#34;:&#34;circle&#34;}" data-widget_type="form.default"><div class="elementor-widget-container"><form class="elementor-form" method="post" name="Subscribe Form"> <input type="hidden" name="post_id" value="84364"/> <input type="hidden" name="form_id" value="69f6bf5b"/> <input type="hidden" name="referer_title" value="How Much Debt Makes It Worth Filing for Bankruptcy? - Newsreports"/> <input type="hidden" name="queried_id" value="93378"/><div class="elementor-form-fields-wrapper elementor-labels-"><div class="elementor-field-type-email elementor-field-group elementor-column elementor-field-group-email elementor-col-60 elementor-md-50 elementor-field-required"> <label for="form-field-email" class="elementor-field-label elementor-screen-only"> Email </label> <input size="1" type="email" name="form_fields[email]" id="form-field-email" class="elementor-field elementor-size-md  elementor-field-textual" placeholder="Your email" required="required" aria-required="true"/></div><div class="elementor-field-group elementor-column elementor-field-type-submit elementor-col-40 e-form__buttons elementor-md-50 elementor-sm-100"> <button type="submit" class="elementor-button elementor-size-md"> <span> <span class=" elementor-button-icon"> </span> <span class="elementor-button-text">Subscribe</span> </span> </button></div></div></form></div></div></div></div></div></section><section class="elementor-section elementor-top-section elementor-element elementor-element-76728b3d elementor-section-height-min-height elementor-section-boxed elementor-section-height-default elementor-section-items-middle" data-id="76728b3d" data-element_type="section"><div class="elementor-container elementor-column-gap-no"><div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-32a33e5d" data-id="32a33e5d" data-element_type="column"><div class="elementor-widget-wrap elementor-element-populated"><div class="elementor-element elementor-element-2863f328 elementor-widget elementor-widget-heading" data-id="2863f328" data-element_type="widget" data-widget_type="heading.default"><div class="elementor-widget-container"><p class="elementor-heading-title elementor-size-default">©2021 Copyright Newsreports - All Rights Reserved</p></div></div></div></div></div></section></div></footer>  <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-167745542-4', 'auto');
ga('send', 'pageview');</script>  <script type="text/javascript" id="eio-lazy-load-js-before">var eio_lazy_vars = {"exactdn_domain":"","skip_autoscale":0,"threshold":0};</script> <script type="text/javascript" id="elementor-pro-frontend-js-before">var ElementorProFrontendConfig = {"ajaxurl":"https:\/\/www.newsreports.com\/wp-admin\/admin-ajax.php","nonce":"1dcc328fec","urls":{"assets":"https:\/\/www.newsreports.com\/wp-content\/plugins\/elementor-pro\/assets\/","rest":"https:\/\/www.newsreports.com\/wp-json\/"},"i18n":{"toc_no_headings_found":"No headings were found on this page."},"shareButtonsNetworks":{"facebook":{"title":"Facebook","has_counter":true},"twitter":{"title":"Twitter"},"linkedin":{"title":"LinkedIn","has_counter":true},"pinterest":{"title":"Pinterest","has_counter":true},"reddit":{"title":"Reddit","has_counter":true},"vk":{"title":"VK","has_counter":true},"odnoklassniki":{"title":"OK","has_counter":true},"tumblr":{"title":"Tumblr"},"digg":{"title":"Digg"},"skype":{"title":"Skype"},"stumbleupon":{"title":"StumbleUpon","has_counter":true},"mix":{"title":"Mix"},"telegram":{"title":"Telegram"},"pocket":{"title":"Pocket","has_counter":true},"xing":{"title":"XING","has_counter":true},"whatsapp":{"title":"WhatsApp"},"email":{"title":"Email"},"print":{"title":"Print"}},"facebook_sdk":{"lang":"en_US","app_id":""},"lottie":{"defaultAnimationUrl":"https:\/\/www.newsreports.com\/wp-content\/plugins\/elementor-pro\/modules\/lottie\/assets\/animations\/default.json"}};</script> <script type="text/javascript" id="elementor-frontend-js-before">var elementorFrontendConfig = {"environmentMode":{"edit":false,"wpPreview":false,"isScriptDebug":false},"i18n":{"shareOnFacebook":"Share on Facebook","shareOnTwitter":"Share on Twitter","pinIt":"Pin it","download":"Download","downloadImage":"Download image","fullscreen":"Fullscreen","zoom":"Zoom","share":"Share","playVideo":"Play Video","previous":"Previous","next":"Next","close":"Close"},"is_rtl":false,"breakpoints":{"xs":0,"sm":480,"md":768,"lg":1025,"xl":1440,"xxl":1600},"responsive":{"breakpoints":{"mobile":{"label":"Mobile","value":767,"default_value":767,"direction":"max","is_enabled":true},"mobile_extra":{"label":"Mobile Extra","value":880,"default_value":880,"direction":"max","is_enabled":false},"tablet":{"label":"Tablet","value":1024,"default_value":1024,"direction":"max","is_enabled":true},"tablet_extra":{"label":"Tablet Extra","value":1200,"default_value":1200,"direction":"max","is_enabled":false},"laptop":{"label":"Laptop","value":1366,"default_value":1366,"direction":"max","is_enabled":false},"widescreen":{"label":"Widescreen","value":2400,"default_value":2400,"direction":"min","is_enabled":false}}},"version":"3.4.7","is_static":false,"experimentalFeatures":{"e_dom_optimization":true,"e_optimized_assets_loading":true,"e_optimized_css_loading":true,"a11y_improvements":true,"e_import_export":true,"additional_custom_breakpoints":true,"theme_builder_v2":true,"hello-theme-header-footer":true,"landing-pages":true,"elements-color-picker":true,"admin-top-bar":true,"form-submissions":true},"urls":{"assets":"https:\/\/www.newsreports.com\/wp-content\/plugins\/elementor\/assets\/"},"settings":{"page":[],"editorPreferences":[]},"kit":{"body_background_background":"classic","active_breakpoints":["viewport_mobile","viewport_tablet"],"global_image_lightbox":"yes","lightbox_enable_counter":"yes","lightbox_enable_fullscreen":"yes","lightbox_enable_zoom":"yes","lightbox_enable_share":"yes","hello_header_logo_type":"logo","hello_header_menu_layout":"horizontal","hello_footer_logo_type":"logo"},"post":{"id":93378,"title":"How%20Much%20Debt%20Makes%20It%20Worth%20Filing%20for%20Bankruptcy%3F%20%E2%80%93%20Newsreports","excerpt":"Most people in the U.S. have some degree of debt. While debt is manageable for some, it\u2019s not so manageable for others.","featuredImage":"https:\/\/www.newsreports.com\/wp-content\/uploads\/2021\/12\/How-Much-Debt-Makes-It-Worth-Filing-for-Bankruptcy-1024x683.jpg"}};</script>  <script defer="" src="https://www.newsreports.com/wp-content/cache/autoptimize/js/autoptimize_f653ec50f9521b52843ded58fc2c9d5c.js"></script><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="newsreports_com",_audins_did=309703;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.newsreports_com,DomainId.309703" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>